首页 学习笔记

WD丢弃算法易语言版本(纯易语言源码)


需要的拿去玩

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 a, 文本型
.局部变量 nSeed, 整数型
.局部变量 b, 字节集
.局部变量 c, 整数型

a = #data
b = 到字节集 (a)
调试输出 (b)
nSeed = getCheckSum (782438439, 到字节集 (a))
调试输出 (nSeed)

nSeed = 位异或 (nSeed, 十六进制 (“AB7932CF”))
调试输出 (nSeed)
调试输出 (取字节集数据 (到字节集 (nSeed), #长整数型, ))

.子程序 getCheckSum, 整数型
.参数 adler, 整数型
.参数 data, 字节集
.局部变量 s1, 整数型
.局部变量 s2, 整数型
.局部变量 i, 整数型

s1 = 位与 (adler, 65535)
s2 = 位与 (右移 (adler, 16), 65535)
.计次循环首 (取字节集长度 (data), i)
    s1 = (s1 + data [i]) % 65521
    s2 = (s2 + s1) % 65521
.计次循环尾 ()
返回 (位或 (左移 (s2, 16), s1))

data

特效仙风散:([255:36,233::5CD38369000101976875:,232:104,"type":8,"imp_item":0,47:1,273:1,])



文章评论